Back to overview
Downtime

EU-FI Server Degradation

Oct 19 at 03:50pm IST
Affected services
Content Delivery Network

Resolved
Oct 19 at 03:51pm IST

CDN Service is online, and we are continuing to monitor status of degradation. We apologize for any inconvenience.

Created
Oct 19 at 03:50pm IST

EU-FI Servers are currently experiencing degradation leading to downtime in our CDN service along with unstable uptime. We are working to identify the root cause of this issue.